What Joomla version should I use?

What Joomla version should I use?

Big news on the Joomla front! It appears the the steering group that runs Joomla has recently updated it's advice on Joomla website building.

Up until recently, it was recommended to launch all new Joomla sites with the LTS (Long Term Support) version 2.5. But with the release in late 2012 of Joomla 3.0 (STL) the Joomla community has had a glimpse into the future of the project.

It has not been recommended to use Joomla 3.0 for any production sites, it was only a short term release and was recommend only for early adopters and developers. However recently that advice changed. The Joomla 3.0 release has been deemed so stable that it is now recommended that all new Joomla sites use Joomla 3.0! Great News!

joomla release cycle

This means any Joomla site we currently build will be supported by the J! Community untill at least the latter part of 2016.

Joomla 4.5 (The next LTS release) is due in March 2016, and as always there will be a few months crossover.

We're all hoping that future upgrades will be smoother, unlike the transition from J1.5 to J2.5. There's plenty of evidence to say this is true, as the upgrade from J2.5 to J3.0 was quite smooth.

What does all this mean in terms WebCraftNI.com's websites? Well it means every new Joomla site we build from April 1st 2013 onwards will be Joomla 3.

I will be adding another blog post explaining the Joomla Release cycle in more detail soon, and also about the advantages of Joomla 3 and what it offers, so watch this space.

 

Related Articles

Leave a comment

You are commenting as guest.

Ready to get started? So are we!


Fill out this simple form and we can get started. You won't regret it!
Copyright © 2017 Webcraftni.com. ALL RIGHTS RESERVED.